If a Saved Filter is used to save the column settings with a name, then the column settings are saved in the database.

If a Saved Filter is Not being used to save the column settings, then the settings are stored in the Registry.


Issue:   

Column settings are not retained for a User after they log out of Spire.


Cause:

If a Saved Filter is not being used and the User logs back in and their column settings are gone, there may be a corrupted Registry Key.


Solution:

The below Registry Key is where you can look for the specific column settings that are not remaining.


HKEY_CURRENT_USER\Software\Spire Systems\Spire\Window State\v2


When you find the key in the above directory, you can rename it with "BU" at the end of the Registry Key name and then log back in to Spire to see if the column settings are now being retained.


Note:

If a Saved Filter is being used and the column settings are not retained, then the Filter will need to be deleted and recreated.